Customer are experiencing issues with logging in

Incident Report for House of Control

Resolved

This incident has been resolved.
Posted Dec 15, 2025 - 10:47 CET

Monitoring

The immediate login problem has been fixed for all users.
We're monitoring to see if there are any remaining issues.
Posted Oct 10, 2025 - 10:02 CEST

Investigating

If you cannot log in - send an email to support@houseofcontrol.com

We experience that customers have issues loggin in. There is a manual workaround - contact us on email.
We're investigating root cause and fix for all users.
Posted Oct 10, 2025 - 07:00 CEST
This incident affected: Complete Control (Complete Control, Region - Norway, Complete Control, Region - Denmark, Complete Control, Region - Cloud, Complete Control, Region - UK).