Login Issues

Incident Report for House of Control

Resolved

This issue has now been resolved, and all users should be able to log in without any problems.
Posted Jun 08, 2026 - 15:33 CEST

Update

We are continuing to investigate this issue.
Posted Jun 08, 2026 - 14:54 CEST

Investigating

We are currently investigating reports from some users who are experiencing difficulties logging into their accounts. Our technical team is actively working to identify and resolve the root cause as quickly as possible.
We sincerely apologize for any inconvenience caused and will provide regular updates here as we have more information.
Posted Jun 08, 2026 - 14:49 CEST
This incident affected: Complete Control (Complete Control, Region - Norway, Complete Control, Region - Denmark, Complete Control, Region - Cloud, Complete Control, Region - UK).